Ruby on Railsでbootstrapを使おう!

開発環境は以下の通り。

  • Ruby : 2.5.1

Bootstrapを入れよう!

Gemfileを追加

以下を追加する。

gem 'bootstrap'
gem 'jquery-rails'

bundle i でインストール実行。

ファイル名を変更しよう & application.scssを修正しよう

  1. cd app/assets/stylesheets/

  2. mv application.css application.scss

  3. vi application.scss に @import “bootstrap”; を追加。

これで修正OK。

application.jsを修正しよう

以下を追記する。

//= require jquery3
//= require popper
//= require bootstrap-sprockets

これでbootstrapが表示されると思います!

バージョンによって相性があるので、使えない場合もあるかもしれませんので

基本処理として参考までにっっ!